Skip to main content

gatsby 謎にビルドできないが謎にビルドできた うーん...

· 5 min read

作業記録ログ

本日の作業

labelmake.jp

  • API連携 使用例 #1301

    • アウトラインを送る
    • アウトラインをもらう
    • アウトラインを修正する
    • APIの導入事例の作成
    • ブログ記事の作成
    • プレスを打つ
  • API連携管理画面データの削除はしない様にする #1591

  • リリース

    なんかまたビルドできないぞ...

    https://github.com/gatsbyjs/gatsby/discussions/34215 この状態に近い 画像の処理で落ちているっぽい。

    とりあえず画像圧縮したコミットがあるのでそれをリバートしてビルドしてみる <- ここから

    だめだった。Parallel Queryが問題っぽい?

    https://github.com/gatsbyjs/gatsby/discussions/34473 で言われている状態と同じかな。

    v3に戻せば動くのか?

    https://github.com/gatsbyjs/gatsby/issues/35055 <- にあるように4.7.2を使う

    昔のコミットに戻してnpx gatsby infoでビルドできるバージョンを確認

      System:
    OS: macOS 12.2.1
    CPU: (8) x64 Apple M1 Pro
    Shell: 5.8 - /bin/zsh
    Binaries:
    Node: 16.14.0 - ~/.nvm/versions/node/v16.14.0/bin/node
    Yarn: 1.22.17 - /usr/local/bin/yarn
    npm: 8.3.1 - ~/.nvm/versions/node/v16.14.0/bin/npm
    Languages:
    Python: 2.7.18 - /usr/bin/python
    Browsers:
    Chrome: 99.0.4844.74
    Firefox: 97.0
    Safari: 15.3
    npmPackages:
    gatsby: ^3.10.2 => 3.10.2
    gatsby-plugin-feed: ^3.10.0 => 3.10.0
    gatsby-plugin-google-analytics: ^3.10.0 => 3.10.0
    gatsby-plugin-hotjar: ^1.1.1 => 1.1.1
    gatsby-plugin-image: ^1.10.1 => 1.10.1
    gatsby-plugin-netlify: ^3.10.0 => 3.10.0
    gatsby-plugin-netlify-cms: ^5.10.0 => 5.10.0
    gatsby-plugin-purgecss: ^6.0.2 => 6.0.2
    gatsby-plugin-react-helmet: ^4.10.0 => 4.10.0
    gatsby-plugin-sass: ^4.10.0 => 4.10.0
    gatsby-plugin-sharp: ^3.10.2 => 3.10.2
    gatsby-plugin-sitemap: ^4.6.0 => 4.6.0
    gatsby-plugin-slug: ^2.0.0 => 2.0.0
    gatsby-plugin-typescript: ^3.10.0 => 3.10.0
    gatsby-plugin-webpack-bundle-analyser-v2: ^1.1.24 => 1.1.24
    gatsby-remark-images: ^5.7.0 => 5.7.0
    gatsby-remark-relative-images: ^2.0.2 => 2.0.2
    gatsby-source-filesystem: ^3.10.0 => 3.10.0
    gatsby-transformer-remark: ^4.7.0 => 4.7.0
    gatsby-transformer-sharp: ^3.10.0 => 3.10.0

    んーーー、わからん。なんかビルドできた。

    ただ、shopifyのアプリのページでビルドできない下記のエラーが発生する。おそらく shopify/polaris が古いのでreactのバージョンのミスマッチだと思う。そこで使用しているuseEffectが問題の原因になっていると思うのでそれのコードを無くしたらビルドできた

    https://reactjs.org/docs/error-decoder.html/?invariant=321

なんか画像の問題なのか、日本語ファイルの問題なのか、画像のビルドでちょくちょくコケる。

  • 管理画面、データ分析基盤の作成 #1554

    とりあえずgasでスプシーに登録していたデータから引っ越す

    herokuにpostgresを作ったので、そこにデータを溜めていき、分析に使う。

    管理画面からの利用者詳細データを置き換える様にする

pdfme

pdfmeのマーケティング #159

  • バッジの追加
  • npmのキーワード設定
  • アイキャッチ設定
  • websiteのogp設定
  • docusaurusのショーケース
  • dev.toで書いた記事のリライト
  • labelmake.jpのブログで書いた記事のリライト

明日の作業

pdfme

  • pdfmeのマーケティング #159

    • バッジの追加

    • npmのキーワード設定

    • アイキャッチ設定

    • websiteのogp設定

    • docusaurusのショーケース

    • dev.toで書いた記事のリライト

    • labelmake.jpのブログで書いた記事のリライト

labelmake.jp

  • 管理画面、データ分析基盤の作成 #1554

    とりあえずgasでスプシーに登録していたデータから引っ越す

    herokuにpostgresを作ったので、そこにデータを溜めていき、分析に使う。

    管理画面からの利用者詳細データを置き換える様にする

  • API連携 使用例 #1301

    • アウトラインを送る

    • アウトラインをもらう

    • アウトラインを修正する

    • APIの導入事例の作成

    • ブログ記事の作成

    • プレスを打つ


日記

ビルドで謎に時間がかかってしまった。。。 気を取り直して明日からはpdfmeのマーケティングとlabelmake.jpのデータ分析基盤の作成を行っていくぞー